Asrofi – Blogger Semarang

Blogger Kendal Blogger Semarang Jawa Tengah

Apache Error Ketika Menghapus Akun di Centos Webpanel

Halo,

Pagi ini sempat stress sebentar, gara-gara masalah komputer server yang error, server untuk website, yang ada di Singapore, yang saya sewa.

Maksud saya komputer VPS.

OS : Centos 7

Software: CWP

KRONOLOGI; 

  1. saya hapus sebuah akun (dan domain dalam akun tersebut tentunya), karena sudah tidak terpakai
  2. kemudian seperti biasa, restart mesin web server yang namanya APACHE,
  3. nah, kali ini aneh, apache error tidak mau jalan.
  4. jadi error ini gara-gara menghapus sebuah akun.
  5. ini sepertinya terjadi di akun-akun yang pakai SSL letsencrypt, prediksi saya.

PENAMPAKAN MASALAH:

  1. Ketika apache tidak jalan, kita coba cek apache status
  2. maka memunculkan pesan error seperti di bawah ini:
● httpd.service - Web server Apache
 Loaded: loaded (/usr/lib/systemd/system/httpd.service; enabled; vendor preset: disabled)
 Active: failed (Result: exit-code) since Tue 2019-04-02 07:19:02 WIB; 39s ago
 Process: 9149 ExecStart=/usr/local/apache/bin/apachectl start (code=exited, status=1/FAILURE)

Apr 02 07:19:02 NAMASERVERMU.NAMA-SERVER-MU.NET systemd[1]: Starting Web server Apache...
Apr 02 07:19:02 NAMASERVERMU.NAMA-SERVER-MU.NET apachectl[9149]: AH00112: Warning: DocumentRoot [/home/DELETED-ACCOUNT/public_html] does not exist
Apr 02 07:19:02 NAMASERVERMU.NAMA-SERVER-MU.NET apachectl[9149]: AH00526: Syntax error on line 132 of /usr/local/apache/conf.d/vhosts-ssl.conf:
Apr 02 07:19:02 NAMASERVERMU.NAMA-SERVER-MU.NET apachectl[9149]: SSLCertificateFile: file '/etc/pki/tls/certs/DELETED-DOMAIN.COM

 

INVESTIGASI:

  1. ada warning akun yang tidak ada
  2. ada warning syntax error pada /usr/local/apache/conf.d/vhosts-ssl.conf

PERCOBAAN SOLUSI:

  1. saya coba buat ulang akun yang terhapus – tidak berhasil – di kasus lain ini berhasil, mungkin katika pembuatannya tanpa SSL
  2. rebuild apache – juga tidak berhasil

SOLUSI AKHIR:

  1. hapus akun kembali (karena tadi sempat dibuat ulang)
  2. kita coba buka file ” /usr/local/apache/conf.d/vhosts-ssl.conf”
  3. cari DELETED-DOMAIN.COM (nama domain milik akun yang dihapus)
  4. cari DELETED-ACCOUNT (nama akun yang dihapus)
  5. ternyata keduanya dalam 1 skrip yang dimulai dari <VirtualHost XXX.XXX.XXX.XXX:8443> dan diakhiri dengan </VirtualHost>
  6. awas, hati-hati, jangan salah hapus, hanya di skrip khusus milik akun yang dihapus tadi.
  7. selesai.
  8. BERHASIL!

Penampakan skrip yang dihapus seperti ini:

<VirtualHost XXX.XXX.XXX.XXX:8443>
 ServerName DELETED-DOMAIN.COM
 ServerAlias www.DELETED-DOMAIN.COM
 ServerAdmin webmaster@DELETED-DOMAIN.COM
 DocumentRoot /home/DELETED-ACCOUNT/public_html
 UseCanonicalName Off
 ScriptAlias /cgi-bin/ /home/DELETED-ACCOUNT/public_html/cgi-bin/

# Custom settings are loaded below this line (if any exist)
 # Include "/usr/local/apache/conf/userdata/DELETED-ACCOUNT/DELETED-DOMAIN.COM/*.conf

SSLEngine on
 SSLCipherSuite ALL:!ADH:+HIGH:+MEDIUM:-LOW:-SSLv2:-EXP
 SSLProtocol All -SSLv2 -SSLv3
 SSLCertificateFile /etc/pki/tls/certs/DELETED-DOMAIN.COM.cert
 SSLCertificateKeyFile /etc/pki/tls/private/DELETED-DOMAIN.COM.key
 SSLCertificateChainFile /etc/pki/tls/certs/DELETED-DOMAIN.COM.bundle
 SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown

<IfModule mod_userdir.c>
 UserDir disabled
 UserDir enabled DELETED-ACCOUNT
 </IfModule>

<IfModule mod_suexec.c>
 SuexecUserGroup DELETED-ACCOUNT DELETED-ACCOUNT
 </IfModule>

<IfModule mod_suphp.c>
 suPHP_UserGroup DELETED-ACCOUNT DELETED-ACCOUNT
 suPHP_ConfigPath /home/DELETED-ACCOUNT
 </IfModule>

<Directory "/home/DELETED-ACCOUNT/public_html">
 AllowOverride All
 </Directory>

</VirtualHost>

 

APACHE-ERROR-CWP-CENTOS-WEBPANEL

Bookmark and Share

Cara Setting Port Forwarding di Mikrotik

Halo,

Kembali ketemu saya lagi, Asrofi.

Kali ini saya akan kembali menulis tentang dunia komputer, ini sebenarnya bukan untuk anda, tapi untuk dokumen pribadi saya, untuk contekan ketika suatu saat saya lupa kembali. Tetapi jika tulisan ini bermanfaat untuk anda tentu saya akan ikut senang.

Baik, sebelum kita bahas setting Port Forwarding di Mikrotik saya akan bahas teorinya dulu, pakai penjelasan 1-2-3 supaya gampang ya.

Jika anda sudah paham tentang port forwarding, langsung lewati saja, ke ujung artikel.

LAN, WAN DAN INTERFACE

  1. dalam jaringan ada WAN dan LAN.
  2. WAN adalah internet, konek ke dunia luar.
  3. LAN adalah jaringan dalam rumah.
  4. kalau di mikrotik kita tidak akan menemukan istilah itu, tetapi kita akan dapat melihat interface, pastikan anda dapat membedakan mana interface untuk WAN dan mana interface untuk LAN
  5. contoh LAN adalah IP lokal yang biasa dipakai orang misalnya 192.168.x.x ataua 10.x.x.x.

SERVER DAN PORT

  1. Ketika kita bicara server atau layanan, misalnya layanan transfer file (ftp), layanan remot desktop, layanan database, layanan billing dan lain-lain maka kita tentu akan bicara ip dan port. si server itu komputernya yang mana, IP nya berapa, juga port layanan nya berapa.
  2. misalnya server ftp pakai port 21.
  3. misal kita dalam jaringan lokal dengan IP 192.168.1.0, dalam jaringan rumah ini ada IP dimulai 192.168.1.1 dan IP terakhir adalah 192.168.1.254.
  4. 192.168.1.1 misalnya yang punya koneksi internet,
  5. 192.168.1.2 misalnya server FTP, dengan port default FTP 21
  6. IP lainnya termasuk laptop IP nya 192.168.1.3 sampai dengan 192.168.1.254
  7. ketika sebuah komputer dalam jaringan memerlukan akses ke server FTP maka yang dipanggil adalah IP 192.168.1.2. ini kalau dilakukan dalam jaringan rumah.
  8. bagaimana kalau kita tidak berada dalam rumah? kita sedang di luar negeri membutuhkan akses ke server FTP yang ada di rumah kita tadi? tentu tidak bisa akses ke IP 192.168.1.2 karena itu IP dalam rumah, bukan IP publik atau bukan IP internet.
  9. maka di sini perlunya PORT FORWARDING atau VIRTUAL SERVER dalam istilah router lain.
  10. jadi nanti kita setting di router kita, misalnya mikrotik. supaya IP lokal tadi dapat diakses dari luar, jadi kalau kita ada di luar, maka kita bisa akses FTP ke ip WAN kita, atau IP publik kita. Port forarding akan menterjemahkan; jika dari luar memanggil port tententu akan diarahkan ke IP tertentu dengan port tersebut.
  11. Contoh di atas dapat disesuaikan dengan kebutuhan lain, misalnya mau konek ke kamera cctv atau ipcam dan lainnya.

 

CARA PORT FORWARDING di MIKROTIK

  1. IP -> FIREWALL -> NAT
  2. tambah baru (+),
  3. kemudian pada GENERAL isikan ini:
  4. chain: DSTNAT,
  5. Protocol: TCP,
  6. DST PORT: (ini diisi port sesuai port server, contoh tadi port ftp 21)
  7. IN.INTERFACE : (Ini pilih interface WAN)
  8. kemudian pada ACTION, isikan ini:
  9. ACTION : DST-NAT
  10. TO ADDRESS: Diisi IP LAN yang melayani server, misalnya tadi 192.168.1.2
  11. TO PORTS: Port server tadi, misalnya server FTP port 21

Okay, begitu cara setting port forwarding di Mikrotik, semoga bermanfaat.

port-forwarding-mikrotik

mikrotik-port-forwarding

Bookmark and Share

Cara Menggunakan OpenDNS Updater Client Pada Mikrotik

Tulisan ini semacam “buku pengingat pribadi”, supaya kalau nanti butuh bisa dibuka kembali, gak perlu browsing-browsing gitu. Tapi kalau kamu baca tulisan ini, dan bisa dipraktekkan ya syukur alhamdulillah.

Oh ya, kembali ke judul ya, jadi bukan hanya OpenDNS tetapi juga berlaku untuk dyamic DNS lain seperti no-ip dan lain-lain, daftar yang disupport ada di sini:

  1. no-ip
  2. dyndns
  3. opendns
  4. dan lain-lain, klik di sini untuk tahu semuanya https://www.dnsomatic.com/wiki/supportedservices .

Okay, langsung aja ya, Cara Menggunakan Dynamic DNS Client Updater Pada Mikrotik sebagai berikut:

  1. daftar di https://www.dnsomatic.com/ . kalau udah punya akun opendns tidak perlu daftar, langsung login aja, karena dnsomatic ini satu perusahaan dengan opendns.
  2. masukin semua servis dns yang anda punya di situ, kalau opendns sudah otomatis ada di situ.
  3. buat script udater ==> SYSTEM -> SCRIPTS  (scriptnya terlampir di akhir tutorial ini) , buat nama script “opendns” misalnya.cara-menggunakan-opendns-di-mikrotik
  4. schedule untuk memanggil script per jam atau per hari, ==> SYSTEM -> SCHEDULER . buat nama scheduler “opendns-scheduler” misalnya, nanti pada “on event” tulis nama scriptnya.cara-setting-open-dns-di-mikrotik

Selesai.

Script DNS O MATIC

  1. script ini dapat berjalan di belakang NAT juga, jadi misalnya mikrotik kita masih di bawah modem, bukan pakai PPPOE langsung juga bisa.
  2. script saya ambil dari sini https://wiki.mikrotik.com/wiki/Dynamic_DNS_Update_Script_for_DNSoMatic.com_behind_NAT.
  3. jangan lupa ganti username dan password dns-o-maitc nya, supaya berfungsi

SCRIPT:

# DNSoMatic automatic DNS updates

#--------------- Change Values in this section to match your setup ------------------

# User account info of DNSoMatic

:local maticuser "USERNAME DNS O MATIC ANDA"
:local maticpass "PASSWORD DNS O MATIC ANDA"

# Set the hostname or label of network to be updated. This is the part after the double colon (::) on the DNSoMatic services page.
# Hostnames with spaces are unsupported. Replace the value in the quotations below with your host names.
# To specify multiple hosts, separate them with commas. 
# Use "all.dnsomatic.com" for the matichost to update all items in dnsomatic with this IP.

:local matichost "all.dnsomatic.com"

#------------------------------------------------------------------------------------

# No more changes need

:global previousIP;

:log info "Fetching current IP"

# Get the current public IP using DNS-O-Matic service.
/tool fetch url="http://myip.dnsomatic.com/" mode=http dst-path=mypublicip.txt

# Read the current public IP into the currentIP variable.
:local currentIP [/file get mypublicip.txt contents]

:log info "Fetched current IP as $currentIP"
 
:if ($currentIP != $previousIP) do={
 :log info "DNSoMatic: Update needed"
 :set previousIP $currentIP
 
# The update URL. Note the "\3F" is hex for question mark (?). Required since ? is a special character in commands.
 :local url "http://updates.dnsomatic.com/nic/update\3Fmyip=$currentIP&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG"
 :local matichostarray;
 :set matichostarray [:toarray $matichost];
 :foreach host in=$matichostarray do={
 :log info "DNSoMatic: Sending update for $host"
 /tool fetch url=($url . "&hostname=$host") user=$maticuser password=$maticpass mode=http dst-path=("dnsomaticupdate-" . $host . ".txt")
 :log info "DNSoMatic: Host $host updated on DNSoMatic with IP $currentIP"
 }
} else={
 :log info "DNSoMatic: Previous IP $previousIP and current IP equal, no update need"
}
Bookmark and Share